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Create a USFBlog (Edublogs) 
 

LEARNING OBJECTIVES 
• Create a new blog 
• Get familiar with the blog interface 
• Learn about basic site features, templates, and settings 

 
First Time Users | Create Account and Make a New Blog 

 
Step 1. If you have never created an account in USF Blogs, do the followings: 
Go to http://usfblogs.usfca.edu, scroll down and click the green ‘Get a Blog ‘button. 

 

 
 
 

Step 2. Enter your USF Username, USF Email address.  Then choose default ‘Gimme a site!’, and 
click Next.  
 
(Note: if you are a student and the system gives you an error for using xxx@dons.usfca.edu, try go 
back and use xx@usfca.edu) 

 

 First time user: Create 
account and new blog 

mailto:xxx@dons.usfca.edu
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Step 3: Enter a Site Name, Site Title, Privacy option. Choose a USF template if desired, and click 
the Signup button.  
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Step 4: Activate link in your email. Open a new browser window and check your email. Click the 
Activate link to activate your blog before going any further. 
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Step 5: After you have activated your email link, you get a confirmation as follows. Now, click the 
Log in link to enter your site. 

 

 
Note:  
If for some reason you have landed on a Wordpress screen, click the [old] USF Connect button and 
authenticate with myUSF username and password.  (You do not need to use the username and 
password Edublog provides you in the email.) *Always log in with your myUSF username and 
password. 
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Step 6:  Themes 
Your blog is defaulted to the basic responsive Edublog template unless you have chosen one of the 
four USF templates when you are setting up your blog.  
 

New:  
Web and Digital Communications has provided four official USF templates for our community 
bloggers.  If you would like to retain the University feel to your blog, please select from any of 
them.  You can also change to any other themes if you later change your mind. 
 

 
 

If you would like to change your blog theme, choose Appearance > Themes 
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**Steps 1-6 above conclude the creation of your new blog.  
 

 
Log in for Returning Users | Signing in to your Existing Blog 

 
If you have already created your account, you are a returning user. 
Go to usfblogs.usfca.edu > click ‘Log In’ and enter your USF username and password 
 
 

 

 
 

 

Returning 
user login 
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Create Multiple Blogs 
 

1. If you wish to create more than one blog, you can do the following after you have 
signed in. 

2. Click My Sites, and choose the Create a New Site link to create additional blogs. 
 

 
 
The Dashboard is your friend! 
Each blog has a Dashboard. To access the Dashboard of a blog, select the blog under My Sites 
and choose Dashboard. 
 

 
 
If you have multiple blogs, always check the top to make sure you are in the correct one. 
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Understanding Posts sand Pages 
   

Posts are organized in reverse-chronological order with dates, authors, categories and tags. 
Posts are posted periodically – daily, weekly, bi-weekly, monthly etc.   Posts can be referenced in 
multiple categories. Items not in any single category can be organized as tags e.g. portrait, 
beauty, healthcare. 

 
Pages are made up of a page title, page content, and comments (most Edublogs themes support 
comments at the bottom of the page to allow readers add comment to your page).  If the theme 
you are using doesn’t support comments on pages, and you would like this feature, then you will 
need to use an alternative theme. 
 
If you have one story/content that you think should belong to the main menu for easy accessibility, 
you should create as page.  It has static content with no date and time stamps or authors.  You can 
also create subpages for each page. For example, biography, contact page, or about me etc.  

 
 
Add New Posts 
 
From the Dashboard, click on Posts > Add New. 
 

Text Formatting 
   

When you are editing, paste contents as Plain text. It’s recommended that you format all text 
inside Wordpress. 
 
Tips:  Use Enter to create a paragraph break.  Use Shift+Enter to create a line break. 

 

Inserting More tag  
  

This will create a line in your story where the rest of the content are invisible until you click on the 
More to go to the full page of the story. 

 

Expand the Kitchen Sink  
  

This should always be displayed to allow you other features in the Editor – headings, text color, 
paste from plain, undo, clear format. 
 
Visual and Text (HTML) View 
 
You can toggle between Design and HTML view by chossing the Visual or Text (HTML) tab. 
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Screen Options  
 
Click to expand Screen Options to get more editing options to your posts. 
 

 
 
 
Creating Links  
 

1. Insert an external link under URL:  e.g. www.google.com 
2. Click the Link icon and type in http://www.google.com.  Title describes this URL. 
3. Check the box next to’ Open link in a new window/tab.’ 
4. Click Add link. 

 
Inserting a relative link 

 
1. Click the Link icon and expand ‘Or Link to existing content’. 
2. You can enter to Search or select from the list of pages. 
3. Click Add link. 
 

 
 

http://www.google.com
http://www.google.com
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Insert an email link 
 

1. Under URL, type mailto:emailaddress@gmail.com 
2. Click Add link. 

 

Removing Links  
 

1. Select existing link, and click the Unlink icon on the Editor. 
 
Post Status 
 
After you are finished with your new post, it becomes a Draft. You can also publish your draft by 
clicking the Publish button, or choose Pending Review to allow other administrarators or editors to 
look at it before publish. 
 
To keep a post private, choose Visibility > Private.  This way, when your post is published, it is not 
visible to your blog’s front page.  You can share the link to this post only with the people you want.  
 

mailto:emailaddress@gmail.com
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Schedule Post 
 
You can schedule the date and time of your post if you don’t want it post immediately. 
 

 
 

Adding Images 
 

Besides text, use Add Media button to add images, videos, audio or tweets to your blog.  
 

1. Click on the Add Media button.  
2. Choose Select Files to upload files from your computer.  
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3. Click the Media Library, enter a Title, Caption and Alt text for your image. 
4. Click Insert into Post button when you are finished. 
 

 
 
Edit Images 

 
After you have inserted an image to your post, and if you need to change an image setting, you 
can click once on the image and select the Edit Image option to open the Edit Image screen. Click X 
to delete the image from your post, however, the image still exists in your images folder. 

 
After you are done with editing your image, click Update. 
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Add a Gallery 
 

1. To add an image gallery to your post, click the Add Media button. 
2. Choose Create Gallery. 
3. Click on select images you want to include in your new gallery. 
4. Then, click the Create a new gallery button after you are finished selecting. 



14 

 
The Center For Instruction and Technology       last updated: 7/11/2016 
 

 

 
 

 
 

 
5. Edit Gallery to make changes, or drag-and-drop to reorder images. 
6. Choose gallery columns and type to display your gallery. (e.g. Slideshow) 
7. Click Insert gallery when you are finished. 
 
Note:  You have to ENABLE Jetpack plugins before you see the Slideshow option. 
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Accessing Media Library from the Dashboard 
 
You can upload media assets to your Media Library through the Dashboard.  
 

1. Choose Media from the Dashboard to see all your media files used in your blog.   
2. Click the Add New button to upload your new image, audio or video files.  
3. You can filter the display by choosing All, Images, Unattached or Show all dates. 

 

 
 

4. If you bring your cursor over the File name, you can also edit, delete or view the file. 
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Adding Videos 
 

1. To insert video, choose Insert Media and select the desired video from your Media 
Library. 

2. To insert YouTube video, go to youTube.com first.  Copy the Embed Code for the video.  
3. Choose Insert Media > Insert Embed Code and paste the URL. 
 

 
 

4. To insert a Vimeo video, simply choose Insert Media > Insert from URL > paste the URL 
of the Vimeo video. 

 
Create Audio or Video Playlist 

 
1. Choose Insert Media and choose Create Video or Audio 

Playlist.  
2. Select files and click Create a New Playlist. 

 
Add Tags and Categories 
 
Categories, unlike tags, are very well defined.  It sorts your posts into 
groups.  The default category in Wordpress is Uncategorized.  You can 
add new categories from the new post screen. 
 
Tags are words or phrases that explain an object.  If you are writing a 
post for a book on blogging, for example, you can use some of the tags 
– blogging, book. You can set as many tags as you like. One thing to 
remember, try to keep tags consistent such as email, e-mail, Email.  
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• On your new post, add the tags and click the Add button. 
• From the Dashboard, you can also add new tags. 

 
Example: 
To better understand tags and categories, let’s say we have a few posts on french and italian 
food, so we can add a new category called Food.  Then we can add tags to the post on Italian 
food – italian cuisine, epicurean, recipes, italy. 
 

 
 

From the Dashboard, you can also add new categories. 
 

 
 

When you are done with your post, you can either save draft first, preview, move to trash, or 
publish it to the web. 
 

 
Edit Page 
To edit a page, click on Edit Page. Or, you can go to your Dashboard > Pages > choose the page 
and click the Edit link. 
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Quick Edits 
To disable comments on pages, you can use Quick Edit.  Go to either Posts > All Posts (or Pages 
> All Pages).  Locate the post or page you want ot disable ocmments on, and hover over it’s title to 
bring up its action menu.  Click on Quick Edit, uncheck ‘Allow Comments’ then click on Update. 
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Enabling Plugins (activate plugins) 
 

Plugins are software that can be uploaded to extend and expand the functionalitiy of Wordpress 
blogs. From the Dashboard, select Plugins > All.  You can search for a particular plugins and click 
the Activate link to activate it.  
 
Search for plugins to activate the use of Jetpack, Contact Form, Google map, Formidable Forms etc. 
 
 
Add Contact Form (activate plugin) 
 

By adding a contact form, your readers will be able to submit feedback to you. All feedback is 
automatically scanned for spam, and the legitimate feedback will be emailed to you. 
 

1. To add a contact form to your post, first choose Plugins > Forms and Surveys > WP 
Contact Form > click to Activate. 

2. Set up form by choosing Settings > choose Contact Form. Enter all fields. 
3. Create a new page Contact. 
4. Important: insert %%wpcontactform%% to your page by pasting into the Visual 

Editor. 
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Add Formidable Form (activate plugin) 

 
1. To add a contact form to your post, first choose Plugins > Forms and Surveys > 

Formidable Form > click to Activate. 
2. From the Dashboard > choose Formidable > New Form. Choose Pre-Built Form or Blank 

Form and click Create.  Set up your form fields. 
3. Once you are done, create a new Page in your blog, and click the New Form button in 

your Editor. 
4. Select the form you want, and click Insert Form button. 
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Add Google Map (activate plugin) 
 

1. Choose Plugins > activate Google Maps. 
2. To add a Google map into your post, click the Add Map button.  
 

 
 
3. Choose the New Map button, enter Title for map, enter Add location. 
4. Click Add Marker, Zoom in to adjust your desired display, and then click Save Changes. 
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5. Once you are finished, click the Insert This Map button. You will now see a map id in your 
Visual Editor.  Click View Page to see your map. 

 

 
 

 
Add Poll (activate this from Jetpack plugin) 
 

1. To add a poll to your post, first choose Plugins > All > Polldaddy Polls and Ratings > 
click to Activate. 

2. From the Dashboard > choose Polls.  
3. You need to first setup a Polldaddy.com account before you can set up your polls. 
4. Follow instruction to create a new poll in Polldaddy.com, and then embed the poll in your 

post. 
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Screen Options - Post Revisions 
 
As you are typing away in your post, Wordpress is tracking your revisions of your post.  If you 
want your post to look like it did an hour ago, you can revert to that saved version.  To do this, you 
need to first enable the Revisions from the Screen Option area. 
 
(Note: If you do not see the Revisions option, make a small edit in the post/page, and click Update. 
This will trigger the Revisions option to show up in the Screen Helper.) 
 

 

 
 
When you click a link for one of your revisions, WordPress will display the two versions for you to 
compare. Choose the versions to compare using the Next button, or check the Compare any two 
versions checkbox.  To restore to the one your want, simply click on Restore This Revision button. 
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Discussion – Trackbacks and Pingbacks 
 
Trackbacks are a way to notify legacy blog systems that you’ve linked to them. If you link other 
WordPress sites they’ll be notified automatically. For example, Person A writes something on their 
blog. Person B wants to comment on Person A's blog, but wants her own readers to see what she 
had to say, and be able to comment on her own blog.  Person B posts on her own blog and sends a 
trackback to Person A's blog. Person A's blog receives the trackback, and displays it as a comment 
to the original post. This comment contains a link to Person B's post. 
 
The best way to think about pingbacks is as remote comments.  The pingback is generally 
displayed on Person A's blog as simply a link to Person B's post.  
 
Visit http://codex.wordpress.org/Introduction_to_Blogging#Managing_Comments for more 
explanation on trackbacks and pingback.) 
 
 

 
 
 
 

http://codex.wordpress.org/Introduction_to_Blogging#Managing_Comments
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Discussion  - Comments 
 
Comments are an important part of your class blog. Comments allow students, and other readers, 
to engage in discussions, share their thoughts and connect with your class blog. Comments transform 
your blog from a static space to an interactive community. 
Important parts of the blogging process include encouraging students to: 
 

1. Read other students’ posts. 
2. Comment on other students’ posts. 
3. Write posts in response to other students’ posts. 

 
To change the comment settings for a post or page you already published you can open the post 
or page for editing and uncheck ‘Allow Comments’ in the Discussion module and then click Update. 
By default, new blogs have the Discussion module hidden. 
 
To enable discussion module as follows: 

 
1. Click on Screen Options in the upper right corner of your dashboard when you have a 

post open in edit mode. 
2. Check the checkbox next to Discussion. 

 

 
 

To disable comments on the post or page 
 

1. Scroll down to the Discussion module. 
2. Uncheck  ‘Allow Comments’. 
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Bulk Edit - Disable Comments on Pages 
 

 
 

1. Go to Posts > All Posts. 
2. Select the posts you want to edit. 
3. Select Edit in the Bulk Actions drop down menu. 
4. Click Apply.   
5. Now select ‘Do not allow from the drop down menu next to Comments’ and then click 

Update. 
 
How to Add Comments on a Post 
 

1. Click on the heading of the post you wish to comment on or the comment link at the top or 
at the bottom of the post. 

2. Scroll down to the page to the comment form or click on Reply (to reply to a specific 
comment). 

3. Enter your name and email address – your email address is hidden and only the blogger 
sees it.  

4. Write your comment. 
5. Enter the anti – spam word. 
6. Select the ‘Notify me of followup comments via e-mail‘ if you want to be notified by 

email to comments by other readers. 
 

Add Pages from the Dashboard 
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Pages are similar to Posts in that they have a title, body text, and associated metadata, but they 
are different in that they are not part of the chronological blog stream, kind of like permanent 
posts. Pages are not categorized or tagged, but can have a hierarchy. You can nest Pages under 
other Pages by making one the ‘Parent’ of the other, creating a group of Pages. 
 
Parent - You can arrange your pages in hierarchies. For example, you could have an “About” 
page that has “Life Story” and “My Dog” pages under it. There are no limits to how many levels 
you can nest pages. 
 
Template - Some themes have custom templates you can use for certain pages that might have 
additional features or custom layouts. If so, you’ll see them in this dropdown menu. 
 
Order - Pages are usually ordered alphabetically, but you can choose your own order by entering 
a number (1 for first, etc.) in this field. 

 

 
 
Create Static Page 
 

If you want your blog to show the static page as your Homepage, you need to create two pages –
one for Homepage, and one for Blog (blog posts). 

 
1. Edit the default About page or create a new page. 
2. Create a new blank Blog page. 
3. After that, go to Settings > Reading > Front Page screen, choose the Homepage as your 

‘Static page’, and choose the Blog page as your Post page. 
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Navigation Menu 
 

1. Choose Dashboard > Appearance > Menus.   
2. Create a new menu if you have not done so.  
3. Enter a Menu name, and then save your menu.   
4. To add pages to the menu, click View All or Search Pages. 
5. Select those pages, and click Add to Menu.   
6. Drag and drop to arrange their order as desired on the Menu Structure. 

Note:  Indented menu will show up as submenu under the Parent menu. (see example) 
7. For Custom Links, enter the URL and Save to Menu.  
8. Under Menu Settings > choose ‘Automatically add new top-level pages to this menu’ 

option, and the ‘Primary Menu’ option. 
9. Click Save Menu when you are finished. 
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To remove unwanted menu, simply click the Remove link. 
 

 



30 

 
The Center For Instruction and Technology       last updated: 7/11/2016 
 

 
 
 

View Comments from the Dashboard 
 

Choose Comment from the Dashboard, you will see each comment showing the dates and the times. 
Hovering over any comment gives you options to approve, reply (and approve), quick edit, edit, 
spam mark, or trash that comment. 
 

 
 
In the In Response To column, there are three elements. The text is the name of the post that 
inspired the comment, and links to the post editor for that entry. The View Post link leads to that 
post on your live site. 
 

Auto Display Comments 
 

If you choose to have the Comments automatically appear, choose Settings > Discussion and set 
as follows: 
 

 

Nested tab 
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Moderate Comments 
 
If you want to moderate your comments, you will need to set Discussions as follows, and have to 
approve them before they appear on your blog. Choose Settings > Discussion and set as follows: 
 

 
 
 
Under Comments in the Dashboard, if there’s comment, it has a red exclamation alerting the 
owner of the blog to approve. See the 3 steps example below. 
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Settings 
 
You can change setting by choosing the Settings in the Dashboard. Just remember to click the Save 
Changes button after you are finished. 
 
General  

 
Title and Tagline, language, date and time stamps are shown on this page. Choose an image to 
upload as your avatar. 

 
Writing  

 
Press This is a bookmarklet: a little app that runs in your browser and lets you grab bits of the 
web. Use Press This to clip text, images and videos from any web page. Then edit and add more 
straight from Press This before you save or publish it in a post on your site. To use Press This, 
simply drag-and-drop the link to your bookmarks bar.  
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Post by Email  

 
You can publish posts using emails with the Post by Email feature. To enable this, visit your My Blogs 
page and create a secret address. 
 
Reading 
 

Display front page settings as blog posts or static page.   
 
For example, when you are in Settings > Reading > Front Page screen, choose the Homepage as 
your ‘Static page’, and choose the Blog page as your Post page. 
 

http://support.wordpress.com/post-by-email/
http://sheerperspectives.wordpress.com/wp-admin/index.php?page=my-blogs
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Privacy Setting - Make a Private Blog 

 

 
 
To make a blog private, choose Dashboard > Settings > Reading, and under Site Visibility, you 
can choose a password, invite new users (Users > Add New) , or only allow registered users to 
access. 
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Discussion 

 
Choose if you would allow comments, and how you would like to receive them.  Choose how 
readers can post comments, and share them, and if you would like to setup notifications via email. 
 
Media  

 
Define the pixel size for your upload images,a nd how you’d like to display your image gallery. 
 
Sharing 

 
Choose whatever social networking sites you’d like to connect your blog to, and automatically share 
new posts with your friends. Add Sharing buttons to your blog and allow your visitors to share posts 
with their friends. 
 
Email Post Changes 

 
Send an email to your email address whenever a post or a page changes if desired. 
 

Users: Manage Users from the Dashboard    
 
From the Dashboard, choose Users > All Users to see all the users on the blog. You can also select 
My Profile to edit your profile picture as an administrator.  Click Invite New to invite and edit 
roles for new collaborators, or choose Remove to remove them.   

 
• Administrator: An administrator has full and complete ownership of a blog, and can 

do absolutely everything. This person has complete power over posts/pages, 
comments, settings, theme choice, import, users – the whole shebang. Nothing is off-
limits, including deleting the entire blog. Only one administrator per blog is 
recommended! 

• Editor: An editor can view, edit, publish, and delete any posts/pages, moderate 
comments, manage categories, manage tags, manage links and upload files/images. 
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• Author: An author can edit, publish and delete their posts, as well as upload 
files/images. 

• Contributor: A contributor can edit their posts but cannot publish them. When a 
contributor creates a post, it will need to be submitted to an administrator for review. 
Once a contributor’s post is approved by an administrator and published, however, it 
may no longer be edited by the contributor. A contributor does not have the ability to 
upload files/images. 

 
Tools 
 
From the Dashboard, choose Tools > Delete Site to delete your blog if desired. Deleting a blog 
removes both the blog name and the content forever. 
 
Choose Export > Download Export File to create an XML file containing your posts and comments 
for you to save to your computer.  You can then import the content on the copies site from another 
WordPress blog. 
 
Appearance 
 
Themes – You can switch to a new template design if desired without affecting your content.  
 
To choose a theme, select from Dashboard > Appearance > Themes.  
 
Click the Preview button on a theme to see how the new template affects your content, and then 
click either Activate or Cancel.  
 
You can also click on the Theme Details button to learn more about a theme; and choose DEMO to 
view a mockup blog site.  The Tags give you an idea of the layout choices of a particular theme. 
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Customization – You can customize your color, emnu, front page, site title, layout and  header. 
Upload your own images if desired. 
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Here’s how to change your theme using the theme customizer: 
 

1. Go to Appearance > Themes. 
2. Click on ‘Live Preview‘ below the theme you want to use. 
3. Or if you want to customize your current theme, click on ‘Customize‘ under the current 

theme. 
4. This loads the customizer.  Now all you do is work through the control panels on the left to 

customize the theme to preview the theme changes in real time before activating it on your 
blog. Once you’re happy with the changes you just click ‘Save & Publish’. 

 
 
Widgets – Different templates allow more or less widgets in the sidebar or footer area.  Click 
Dashboard >Appearance >Widgets to start configuring your widgets. To add a widget to the 
widget area, simply drag-and-drop the desired widgets from left to right. 

 
 
 
 
 
 

FAQ 
 
Can I upload my own theme? 
 
Because of  the way blog platforms like Edublogs, WordPress.com and Blogger work you can only 
use the themes provided and can’t upload your own custom themes.  Most themes are designed to 
work on single installs and many don’t work or can have compatibility issues on blog platforms. 
 
Remember that custom image headers and backgrounds are a very effective way of customizing 
your theme to meet your needs. 
 
How do I change the font color, font size and text color? 
 
Some themes have extensive theme customization options which aren’t supported by the theme 
customizer. 
 
They often include options to change font color, font size and text color. 
 
These types of themes add a theme option menu item under Appearance once the theme is 
activated. 
 
To do more extensive customization you just need to go to Appearance > Theme Options. 
 
You can also change font type, size and color in posts or on pages using the Supreme Google 
Webfonts plugin. 
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RSS Widget 
 
 
 

 
 
 

 
Mobile and iPad – Determine if you wish to customize your blog differently for the mobile and 
iPad devices. 
 
Site Stats 
 
Choose Dashboard > Settings > Google Analytics to see all visitors activities on your blog. 

 
Help  
 
Click the Edublogs logo and choose Help and Support to use the User Guide and step-by-step 
tutorial on Student Blogging. 
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Resources: 
 
 
User Guide 
http://help.edublogs.org/user-guide/ 
 
Choose your Theme 
http://help.edublogs.org/choosing-your-theme/ 
 
Plugins: 
http://help.edublogs.org/?s=plugins 
 
To embed video:  
http://help.edublogs.org/embedding-videos-from-video-sharing-websites-into-your-posts/ 
 
To embed audio:  
http://help.edublogs.org/embed-audio/ 
 
Editing CSS 
http://help.edublogs.org/editing-css/ 
 
Privacy: 
http://help.edublogs.org/blog-privacy/ 
 
Online Training:  
lynda.com (via myusf.usfca.edu > Fav Apps > Learning Technologies tab ) 
http://help.edublogs.org/webinars-and-live-training/ 
 
Blogging with Students: 
http://help.edublogs.org/user-guide/students-and-classes/ 
 
 
 

http://help.edublogs.org/user-guide/
http://help.edublogs.org/choosing-your-theme/
http://help.edublogs.org/?s=plugins
http://help.edublogs.org/embedding-videos-from-video-sharing-websites-into-your-posts/
http://help.edublogs.org/embed-audio/
http://help.edublogs.org/editing-css/
http://help.edublogs.org/blog-privacy/
http://help.edublogs.org/webinars-and-live-training/
http://help.edublogs.org/user-guide/students-and-classes/

