Create a USFBlog (Edublogs)

LEARNING OBJECTIVES

• Create a new blog
• Get familiar with the blog interface
• Learn about basic site features, templates, and settings

Signing up for a New Blog

1. Go to http://usfblogs.usfca.edu, and click the Get a Blog button.

2. Enter a username and email address and choose ‘Gimme a site!’, then click Next to begin.
Sign In to an Existing Blog

1. Signing in if you already have an account, simply click Login.

Create Multiple Blogs

1. After signed in, click My Sites, and choose the Create a New Site link to create new blogs.

The Dashboard is your friend!
Each blog has a Dashboard. To access the Dashboard of a blog, select the blog under My Sites and choose Dashboard.
Understanding Posts and Pages

**Posts** are organized in reverse-chronological order with dates, authors, categories and tags. Posts are posted periodically – daily, weekly, bi-weekly, monthly etc. Posts can be referenced in multiple categories. Items not in any single category can be organized as tags e.g. portrait, beauty, healthcare.

**Pages** are static content with no date and time stamps or authors. You can even create subpages for each page. If you have one story/content that you think should belong to the main menu for easy accessibility, you should create as page. For example, biography, contact page, or about me etc. You can create your pages based on page templates.

Add New Posts

From the **Dashboard**, click on **Posts > Add New**.

Text Formatting

When you are editing, paste contents as **Plain text**. It’s recommended that you format all text inside Wordpress.
**Tips:** Use **Enter** to create a paragraph break. Use **Shift+Enter** to create a line break.

**Inserting More tag**

This will create a line in your story where the rest of the content are invisible until you click on the **More** to go to the full page of the story.

**Expand the Kitchen Sink**

This should always be displayed to allow you other features in the Editor – headings, text color, paste from plain, undo, clear format.

**Visual and Text (HTML) View**

You can toggle between Design and HTML view by choosing the **Visual** or **Text (HTML) tab**.

**Screen Options**

Click to expand **Screen Options** to get more editing options to your posts.

```
Show on screen
- Post Status
- AddThis
- Format
- Categories
- Tags
- Featured Image
- Revisions
- Excerpt
- Send Trackbacks
- Custom Fields
- Discussion
- Comments
- Slug
- Author

Screen Layout
Number of Columns: 1

Enable full-height editor and distraction-free functionality.
```

**Creating Links**

1. Insert an external link under URL: e.g. [www.google.com](http://www.google.com)
2. Click the **Link** icon and type in [http://www.google.com](http://www.google.com). Title describes this URL.
3. Check the box next to’ **Open link in a new window/tab’.**
4. Click **Add link**.

**Inserting a relative link**

1. Click the **Link** icon and expand ‘**Or Link to existing content**’.
2. You can enter to Search or select from the list of pages.
3. Click **Add link**.
Insert an email link

1. Under **URL**, type `mailto:emailaddress@gmail.com`
2. Click **Add link**.

Removing Links

1. Select existing link, and click the **Unlink** icon on the Editor.
Post Status

After you are finished with your new post, it becomes a Draft. You can also publish your draft by clicking the Publish button, or choose Pending Review to allow other administrators or editors to look at it before publish.

To keep a post private, choose Visibility > Private. This way, when your post is published, it is not visible to your blog's front page. You can share the link to this post only with the people you want.

Schedule Post

You can schedule the date and time of your post if you don't want it post immediately.
Adding Images

 Besides text, use Add Media button to add images, videos, audio or tweets to your blog.

 1. Click on the Add Media button.
 2. Choose Select Files to upload files from your computer.

 3. Click the Media Library, enter a Title, Caption and Alt text for your image.
 4. Click Insert into Post button when you are finished.
Adding Videos

1. To insert video, choose **Insert Media** and select the desired video from your Media Library.
2. To insert **YouTube video**, go to **youTube.com** first. Copy the **Embed Code** for the video.
3. Choose **Insert Media > Insert Embed Code** and paste the URL.

4. To insert a **Vimeo video**, simply choose **Insert Media > Insert from URL** > paste the URL of the Vimeo video.

Edit Images

After you have inserted an image to your post, and if you need to change an image setting, you can click on the image and select the **Edit Image** option to open the Edit Image screen. Click **X** to delete the image from your post, however, the image still exists in your images folder.

After you are done with editing your image, click **Update**.
Add a Gallery

1. To add an image gallery to your post, click the **Add Media** button.
2. Choose **Create Gallery**.
3. Click on select images you want to include in your new gallery.
4. Then, click the **Create a new gallery** button after you are finished selecting.
5. **Edit Gallery** to make changes, or drag-and-drop to reorder images.
6. Choose gallery columns and type to display your gallery. (e.g. Slideshow)
7. Click **Insert gallery** when you are finished.
Add Tags and Categories

Categories, unlike tags, are very well defined. It sorts your posts into groups. The default category in Wordpress is *Uncategorized*. You can add new categories from the new post screen.

Tags are words or phrases that explain an object. If you are writing a post for a book on blogging, for example, you can use some of the tags – blogging, book. You can set as many tags as you like. One thing to remember, try to keep tags consistent such as email, e-mail, Email.

- On your new post, add the tags and click the Add button.
- From the Dashboard, you can also add new tags.

Example:
To better understand tags and categories, let’s say we have a few posts on French and Italian food, so we can add a new category called *Food*. Then we can add tags to the post on Italian food – *Italian cuisine, epicurean, recipes, Italy*. 
From the Dashboard, you can also add new categories.

When you are done with your post, you can either save draft first, preview, move to trash, or publish it to the web.

Add Contact Form

By adding a contact form, your readers will be able to submit feedback to you. All feedback is automatically scanned for spam, and the legitimate feedback will be emailed to you.

1. To add a contact form to your post, first choose Plugins > Forms and Surveys > WP Contact Form > click to Activate.
2. Set up form by choosing Settings > choose Contact Form. Enter all fields.
3. Create a new page Contact.
4. Important: insert %%wpcontactform%% to your page by pasting into the Visual Editor.
Add Formidable Form

1. To add a contact form to your post, first choose Plugins > Forms and Surveys > Formidable Form > click to Activate.
2. From the Dashboard > choose Formidable > New Form. Choose Pre-Built Form or Blank Form and click Create. Set up your form fields.
3. Once you are done, create a new Page in your blog, and click the New Form button in your Editor.
4. Select the form you want, and click Insert Form button.
Add Google Map

2. To add a Google map into your post, click the Add Map button.

3. Choose the New Map button, enter Title for map, enter Add location.
4. Click Add Marker, Zoom in to adjust your desired display, and then click Save Changes.
5. Once you are finished, click the **Insert This Map** button. You will now see a map id in your Visual Editor. Click **View Page** to see your map.

---

**Add Poll**

1. To add a poll to your post, first choose **Plugins > All > Polldaddy Polls and Ratings** > click to **Activate**.
2. From the **Dashboard > choose Polls**.
3. You need to first setup a Polldaddy.com account before you can set up your polls.
4. Follow instruction to create a new poll in Polldaddy.com, and then embed the poll in your post.
Writing Helper and Feedback Request (Wordpress blogs)

If you would like somebody to review your draft before you publish, you can click on Writing Helper area, and send a request to your co-editor. You can also customize your message before it goes out or get a shared link so that your co-editor has the link to put in a comment.

Before you do this, enable the Writing Helper on your Screen Option, then below your post, you will see the Request Feedback option. Simply click on it to bring up the Writing Helper screen to enter an email address.
Once you’ve sent requests for feedback, whenever you visit the blog edit page again and go to the **Request Feedback** section you’ll see all of the people you’ve sent invites to. If they’ve responded with any feedback, you’ll see that too.

If anyone ever requests feedback from you, you’ll get an email with a special link just for you. Don’t share it, or else other people will be able to leave feedback “as you.” The link will take you to a page that looks mostly like an ordinary blog post, with two key differences. First, the post you see will be a draft that hasn’t been published yet, so no one else can see it unless they have been invited. Second, there will be a new sidebar on the left side of the page with a form to leave your
feedback. This works pretty much like a comment form and anything you type in there, once you submit it, will be sent to the blog’s author for review.

For posts where you request feedback you can publish them just like any other post. When you do, we’ll send an email to each of the people you requested feedback from letting them know that they post was published and with a link so that they can read the results of their hard work.

If you ever change your mind and decide you don’t want someone to see your post before it’s published, click the Uninvite link under any invitee row. That will disable their special link and prevent them from seeing your post or sending you feedback.

Post Revisions

As you are typing away in your post, Wordpress is tracking your revisions of your post. If you want your post to look like it did an hour ago, you can revert to that saved version. To do this, you need to first enable the Revisions from the Screen Option area.

When you click a link for one of your revisions, WordPress will display the two versions for you to compare. Choose the versions to compare using the Next button, or check the Compare any two versions checkbox. To restore to the one you want, simply click on Restore This Revision button.
Discussion – Trackbacks and Pingbacks

Trackbacks are a way to notify legacy blog systems that you’ve linked to them. If you link other WordPress sites they’ll be notified automatically. For example, Person A writes something on their blog. Person B wants to comment on Person A’s blog, but wants her own readers to see what she had to say, and be able to comment on her own blog. Person B posts on her own blog and sends a trackback to Person A’s blog. Person A’s blog receives the trackback, and displays it as a comment to the original post. This comment contains a link to Person B’s post.

The best way to think about pingbacks is as remote comments. The pingback is generally displayed on Person A’s blog as simply a link to Person B’s post.

Visit [http://codex.wordpress.org/Introduction_to_Blogging#Managing_Comments](http://codex.wordpress.org/Introduction_to_Blogging#Managing_Comments) for more explanation on trackbacks and pingback.)

Accessing Media Library from the Dashboard

You can upload media assets to your Media Library through the Dashboard.

1. Choose Media from the Dashboard to see all your media files used in your blog.
2. Click the **Add New** button to upload your new image, audio or video files.
3. You can filter the display by choosing **All, Images, Unattached or Show all dates**.

4. If you bring your cursor over the File name, you can also **edit, delete or view** the file.

![Media Library](image)

### Create Audio or Video Playlist

1. Choose **Insert Media** and choose **Create Video or Audio Playlist**.
2. Select files and click **Create a New Playlist**.

### Add Pages from the Dashboard

![Pages](image)

**Pages** are similar to Posts in that they have a title, body text, and associated metadata, but they are different in that they are not part of the chronological blog stream, kind of like permanent posts. Pages are not categorized or tagged, but can have a hierarchy. You can nest Pages under other Pages by making one the ‘Parent’ of the other, creating a group of Pages.

**Parent** - You can arrange your pages in hierarchies. For example, you could have an “About” page that has “Life Story” and “My Dog” pages under it. There are no limits to how many levels you can nest pages.
**Template** - Some themes have custom templates you can use for certain pages that might have additional features or custom layouts. If so, you'll see them in this dropdown menu.

**Order** - Pages are usually ordered alphabetically, but you can choose your own order by entering a number (1 for first, etc.) in this field.

---

**Create Static Page**

1. Edit the default About page or create a new page.
2. Create a new blank Blog page.
3. When you are in Settings > Reading > Front Page screen, choose the Homepage as your ‘Static page’, and choose the Blog page as your Post page.

**Navigation Menu**

1. Choose Dashboard > Appearance > Menus.
2. Create a new menu if you have not done so.
3. Enter a Menu name, and then save your menu.
4. To add pages to the menu, click View All or Search Pages.
5. Select those pages, and click Add to Menu.
6. Drag and drop to arrange their order as desired on the Menu Structure.
   
   **Note:** Indented menu will show up as submenu under the Parent menu. (see example)
7. For Custom Links, enter the URL and Save to Menu.
8. Under **Menu Settings** > choose ‘Automatically add new top-level pages to this menu’ option, and the ‘Primary Menu’ option.
9. Click **Save Menu** when you are finished.
To remove unwanted menu, simply click the Remove link.

View Comments from the Dashboard

Choose Comment from the Dashboard, you will see each comment showing the dates and the times. Hovering over any comment gives you options to approve, reply (and approve), quick edit, edit, spam mark, or trash that comment.
In the **In Response To** column, there are three elements. The text is the name of the post that inspired the comment, and links to the post editor for that entry. The **View Post** link leads to that post on your live site.

**Settings**

You can change setting by choosing the **Settings** in the **Dashboard**. Just remember to click the **Save Changes** button after you are finished.

**General**

Title and Tagline, language, date and time stamps are shown on this page. Choose an image to upload as your avatar.

**Writing**

**Press This** is a bookmarklet: a little app that runs in your browser and lets you grab bits of the web. Use **Press This** to clip text, images and videos from any web page. Then edit and add more straight from Press This before you save or publish it in a post on your site. To use **Press This**, simply drag-and-drop the link to your bookmarks bar.
Post by Email

You can publish posts using emails with the Post by Email feature. To enable this visit your My Blogs page and create a secret address.

Reading

Display front page settings as blog posts or static page.

For example, when you are in Settings > Reading > Front Page screen, choose the Homepage as your ‘Static page’, and choose the Blog page as your Post page.

Privacy Setting - Make a Private Blog

To make a blog private, choose Dashboard > Settings > Reading, and under Site Visibility, you can choose a password, invite new users (Users > Add New), or only allow registered users to access.
Public Blogs with two options:

Allow search engines to index this site. — This is the setting used by most blogs. It allows everyone to read your blog and enables your blog to be included in search engine results and other content sites.

Discourage search engines from indexing this site. — If you want all human visitors to be able to read your blog, but want to block web crawlers for search engines, this is the setting for you.

Discussion

Choose if you would allow comments, and how you would like to receive them. Choose how readers can post comments, and share them, and if you would like to setup notifications via email.

Media

Define the pixel size for your upload images, and how you’d like to display your image gallery.

Sharing

Choose whatever social networking sites you’d like to connect your blog to, and automatically share new posts with your friends. Add Sharing buttons to your blog and allow your visitors to share posts with their friends.

Email Post Changes

Send an email to your email address whenever a post or a page changes if desired.
Users: Manage Users from the Dashboard

From the Dashboard, choose Users > All Users to see all the users on the blog. You can also select My Profile to edit your profile picture as an administrator. Click Invite New to invite and edit roles for new collaborators, or choose Remove to remove them.

- **Administrator**: An administrator has full and complete ownership of a blog, and can do absolutely everything. This person has complete power over posts/pages, comments, settings, theme choice, import, users – the whole shebang. Nothing is off-limits, including deleting the entire blog. *Only one administrator per blog is recommended!*
- **Editor**: An editor can view, edit, publish, and delete any posts/pages, moderate comments, manage categories, manage tags, manage links and upload files/images.
- **Author**: An author can edit, publish and delete their posts, as well as upload files/images.
- **Contributor**: A contributor can edit their posts but cannot publish them. When a contributor creates a post, it will need to be submitted to an administrator for review. Once a contributor’s post is approved by an administrator and published, however, it may no longer be edited by the contributor. A contributor does not have the ability to upload files/images.

Tools

From the Dashboard, choose Tools > Delete Site to delete your blog if desired. Deleting a blog removes both the blog name and the content forever.

Choose Export > Download Export File to create an XML file containing your posts and comments for you to save to your computer. You can then import the content on the copies site from another WordPress blog.

Appearance

**Themes** – You can switch to a new template design if desired without affecting your content. Choose from Dashboard > Appearance > Themes. Click the Preview button on a theme to see how the new template affects your content, and then click either Activate or Cancel. You can also click on the Theme Details button to learn more about a theme; and choose DEMO to view a mockup blog site. The Tags give you an idea of the layout choices of a particular theme.
The Center For Instruction and Technology

**Twenty Ten**

The 2010 theme for WordPress is stylish, customizable, simple, and readable — make it yours with a custom menu, header image, and background. Twenty Ten supports six widgetized areas (two in the sidebar, four in the footer) and featured images (thumbnails for gallery posts and custom header images for posts and pages). It includes stylesheets for print and the admin Visual Editor, special styles for posts in the “Aside” and “Gallery” categories, and has an optional one-column page template that removes the sidebar.

**Tags:** black, blue, white, two-columns, fixed-layout, custom-header, custom-background, threaded-comments, sticky-post, translation-ready, microformats, rtf-language-support, editor-style, custom-menu, flexible-header

**Noteworthy**

Noteworthy is a theme that is proudly inspired by USA Today. Perfect for news and magazine style blogs and even photo galleries. The theme features social media buttons which are easily set up through a theme options page in the admin.

**Categories:** Mobile Friendly, Popular, Magazine, Class, Portfolio

**Tags:** custom-menu, sticky-post, microformats, rtf-language-support, translation-ready, full-width-template, post-formats

**Sheer Perspectives**

Wisdom comes clear in balanced views

**test post**

- February 2014 [1]
Customization – You can customize your color, menu, front page, site title, layout and header. Upload your own images if desired.

Widgets – Different templates allow more or less widgets in the sidebar or footer area. Click Dashboard > Appearance > Widgets to start configuring your widgets. To add a widget to the widget area, simply drag-and-drop the desired widgets from left to right.

RSS Widget

Enter the RSS feed URL here:
http://feeds.feedburner.com/lyndacom-new-releases

Give the feed a title (optional):

How many items would you like to display? 10

☐ Display item content?

☐ Display item author if available?

☐ Display item date?

Delete | Close
**Mobile and iPad** – Determine if you wish to customize your blog differently for the mobile and iPad devices.

**Disable Comments on Pages**

1. Posts > All Posts > select the post(s)
2. Under Bulk Actions > Edit > Apply
3. Comments > Allow or Do Not Allow
4. Click the Update button

**Site Stats**

Choose Dashboard > Settings > Google Analytics to see all visitors activities on your blog.
Help

Click the Edublogs logo and choose Help and Support to use the User Guide and step-by-step tutorial on Student Blogging.

Resources:

User Guide
http://help.edublogs.org/user-guide/

Choose your Theme
http://help.edublogs.org/choosing-your-theme/

Editing CSS
http://help.edublogs.org/editing-css/

To embed video:
http://help.edublogs.org/embedding-videos-from-video-sharing-websites-into-your-posts/

To embed audio:
http://help.edublogs.org/embed-audio/

Privacy:
http://help.edublogs.org/blog-privacy/

Online Training:
Lynda.com (via myusf.usfca.edu > Fav Apps > Learning Technologies tab )

http://help.edublogs.org/webinars-and-live-training/