Getting Started with Google Forms

Learning Objectives

• Create form and add questions, image and video
• Structure your questions
• Share your form
• Examine data
• Email Notification

Create and Name your Form

1. Login to myUSF, and choose Email. (OR choose All Apps > Fac/Staff Drive)
2. Click the New button and choose More > Google Forms.
3. Enter a Title for your form. Choose a Theme. Then click OK.
4. Choose appropriate Form Settings.
5. Start creating your questions.

‘Allow Only One Submission’ is Possible!
Please note if you enable this feature, all respondents must have a Google account to log in as required. If you rather have the Form open to all users, you could instead ask for a unique piece of information, such as an e-mail address or name. You will then be able to filter out duplicates in your responses using spreadsheet functions.

Edit Questions

1. Click the Edit icon next to each of the existing question to edit content.
2. Start with adding a Question Title.

3. Then, under Help Text, type your question or leave blank.
4. Choose a Question Type for your question. You can choose different types of questions to your form. Here are some of the question types you can choose: paragraph text checkboxes, choose from a list, multiple choice, scale, grid, date, and time.

5. Check the box next to ‘Required question’ if your question is required.
Add New Question

1. Click on the down-arrow next of the Add item button to create a new question. Select the type of question you would like to add.
2. Select Section header or Page break from the Add item drop-down menu to divide your form into sections or pages to direct users to different groups of questions.

Data Validation Settings
Currently, only Text, Paragraph text, and Checkboxes questions have support for validation. Each question type has its own validation settings. (see Data Validation settings and examples on last page).

Duplicate Questions
Click on the icon to duplicate a question, then click and drag it to the proper location in the form.

Delete Questions
Click to delete a question.

Reorder Questions
Select the desired question, when you see the cursor turned into a four-headed arrow, drag and drop the question to another location.

Text
Text allows you to type in a short answer such as name and address; allows data validation.

Paragraph Text (Comments)
Paragraph text allows you to enter a large text entry such as comments; allows data validation.
Multiple Choices
Users can only select one choice from the list.

Checkboxes
Checkboxes allows you to choose more than one item from a list; allows data validation.

Choose from a List
This is a drop-list. Users can only select one choice from the list.

NEW - Improved copy-and-paste will let you copy a list of bullets from the web or multiple rows of text from a spreadsheet; then, when you paste into a form, each line will be appear as an individual answer.

Questions on a Scale
Scale questions allows you rate something on a scale of whatever number you would like to set e.g. on a scale of 1-5 with 5 being the highest.

Adding Page Break
If you've created a long form, for example, and would like to make it easier for your respondents to fill out, you can add page breaks.

1. From Add item drop-down menu> select Page break.

Once you have created your Page Break, you can start to add new section header and questions under the new page.
IMPORTANT: Make sure that you select the appropriate page number to continue at the end of each page. (see example below)

Adding Section Header

If your form is lengthy, you can organize it into different sections. One way to manage this is to add Section Header to describe the different section layouts in your form.

1. From Add item drop-down menu > select Section Header.
2. Once you have created your Section Header, you can start to add Header Text and an optional Description for the section.

Allowing Navigation to a Specific Page (setup conditional questions in MC)

You can allow users to go directly to the appropriate section from a Multiple Choice question type by checking the box ‘Go to a page based on answer’. Choose the correct page to go to for each answer.

Note: This feature is available for multiple choice question type only.

IMPORTANT: After the participants have finished answering the survey questions based on an answer, choose ‘Submit form’ page and direct them to end survey.
Add Image and Video
Choose Add item > Layout > Video or images.
Saving Form
Every time you make changes to your form, it is **automatically saved** in your Google Drive.

**Edit Confirmation Message**

1. Google Form automatically creates the Confirmation Page at the bottom of your form.
2. Enter your own confirmation message. Check if you would like to ‘**Publish and show a link to the results of this form**’ or ‘**Allow responders to edit responses after submitting**’.
3. Once you are done, click **Send form** button.
4. You have a choice to send your form via email, Google+, Facebook or Twitter, or even embed it in your website by using the Embed code.
5. For email, enter the recipient’s emails. Customize your message and subject line. Then click **Send**.
6. You can also click on **Add Collaborators** to invite other editors to this form.
Choose a Form Response Destination

After you’ve sent out your form, Google Forms will begin collecting the responses you receive. You will decide how you’d like to store these responses. (Note: You can edit this choice at any time while editing your form by clicking the Choose response destination button in the toolbar.)

You can choose either to send responses to a spreadsheet, or you can store them only in Forms (new feature as of January 2013). If you choose to store them in a spreadsheet, you’ll be able to see individual responses as they come in. If you choose to store them in Forms, you’ll only be able to see a summary of all the responses you’ve received, and you’ll also be able to download the responses as a CSV file.

Store responses in a Spreadsheet

Option 1: New Spreadsheet (see below diagram)

1. In the ‘Choose response destination’ dialog, you can choose to create a new spreadsheet in which to store your form’s responses.

2. Enter a new title for the new spreadsheet.

If you’d like all of your forms to collect responses in a new spreadsheet in the future, make sure the checkbox next to ‘Always create a new spreadsheet’ is selected.
Option 2: New Sheet in an existing spreadsheet (see below diagram)

1. Alternatively, you can choose to collect responses in a new sheet of an existing spreadsheet. Choose ‘New sheet in an existing spreadsheet...’ and click Choose.

2. You’ll see a list of all your existing spreadsheets. Pick a spreadsheet by checking the box next to it and click Select. A new sheet will be created inside that spreadsheet, and your form responses will be stored in there.

Once you've chosen to store form responses in a spreadsheet, the Choose response destination button in the toolbar will turn into a View responses button. Click this to see your spreadsheet. You can also find the spreadsheet in your Drive.
Note that responses sent to a spreadsheet are essentially a copy of your responses and are only sent one way — form to spreadsheet, not spreadsheet to form. In other words, if you modify a response in your spreadsheet, you’re not changing the original response, which will show up in summary view or the CSV download.

Change your response destination
If you’ve chosen a spreadsheet in which to store your form responses, you can change this destination at any time by clicking on the Responses menu in Forms and selecting Change response destination. You’ll be taken back to the ‘Choose response destination’ dialog, where you can create a new spreadsheet or send responses to another existing spreadsheet.

Store responses only in Forms
Keeping responses in Forms is a good way to go if you expect your form to receive heavy traffic or a significant number of responses, as spreadsheets will hold only the first 400,000 cells of response values. Your form’s summary view, as well as the results you download as a CSV, will always reflect all of the form responses that are submitted, even beyond these limits.

Option 3: Keep responses only in Forms (see ‘Option 3’ in the previous diagram)

1. If you don’t want responses to go to a spreadsheet, click the Keep responses only in Forms button.

2. Then, to access the responses you’ve collected, click the File > Download as, and click Comma Separated Values.

However, if you have previously linked the form to a spreadsheet, you will need to first unlink the spreadsheet.

Unlink Spreadsheet
You can choose to unlink your form from a spreadsheet at any given time by clicking on the Responses menu in Forms and selecting Unlink form. The spreadsheet will no longer receive new responses, but responses will continue to be stored in Forms, available as a real-time summary or as a CSV file. You can choose to re-link your form to a spreadsheet at any time with no responses lost or deleted.

View Responses in Spreadsheet or in Form
- If you store your data to a spreadsheet, click View responses to see your data.
- If you store your data in the form, click Responses > Summary of responses to see charted data, or choose File > Download as > Comma Separated Values to download data.

View Responses in Spreadsheet
When form data is linked to a spreadsheet, and you edit the data manually, Google will save the edited data as another spreadsheet in your Drive. When users continue to fill out the form
with new data, the new records will continue to copy to the original spreadsheet, not the edited spreadsheet.

View Live Form in Spreadsheet
   • Choose View > Live Form.

Go to Live Form in Spreadsheet
   • Choose Form > Go to Live Form.

Edit Form in Spreadsheet
   • Choose Form > Edit Form.

See Revision History in Spreadsheet
If you have edited the form data in the spreadsheet view, and would like to review the revision history, choose File > See revision history.

Duplicate Form in Spreadsheet
Sometimes, you might want to use an existing form as a base template, where you can modify it slightly and save it for another purpose. In this case, you can duplicate the form.

1. In your form, choose File > Make a Copy to copy the existing form.
2. Then, Rename your form. Select ‘Share it with the same people’ if desired.

Spreadsheet Data
If you remove a question from the form, the previous data and the column will NOT be deleted from the spreadsheet, but of course, the column will no longer be filled with any new data.

If you add a new question to your form, new form responses will be added after the last column in the spreadsheet.

Here are some changes you can make to the spreadsheet:

• You can insert columns to add your own content, such as calculations, notes, or lookups, next to form responses.
• You can add response data directly to the spreadsheet by adding rows above, below, or between your existing response rows. You can add data one row at a time, or paste it in bulk.
• Some changes to your spreadsheet aren’t allowed. For example, you can’t move columns in the table from side to side since doing so would disrupt the structure of the table.

Monitor for Multiple Submissions
As you’re reviewing the responses, keep in mind that you can’t prevent users from submitting a form more than once, so the same person may have submitted multiple responses. If you use Google Apps, however, you can choose to record the email addresses of people who fill out your form, and then easily identify any duplicate responses.

Allow Form Respondents to View the Summary of Responses
You can allow those who filled out your form to see a summary of the responses. Select the option ‘Publish and show a link to the results of this form’ in the Confirmation page to make the summary viewable to everyone. Allow responders to edit responses after submitting by choosing the ‘Allow responders to edit responses after submitting’.

Share Spreadsheet data
1. From your spreadsheet top menu, choose File > Share.
2. Add collaborators emails to allow them to View, Edit or Comment on your form data in the Sharing Settings.
3. Click the **Share and Save** button when you are finished.

**Stop Accepting Response**

In your form, select ‘**Not accepting responses**’ to close your survey. Click on it again to revert.

**Add-Ons**

Add-ons are scripts built by third-party developers to add more functionality to your documents, spreadsheets, and forms. You can turn them on and off at any time, and manage each one individually.

1. Open your form, click the **Add-ons** menu, and then choose **Get Add-ons**.
2. Click the **Free** button to install the add-on. **Accept terms**.

Try these add-ons: **Remove Duplicates, Email Notification, Split Names**!
Setup Email Notification using Simple Scripts (advanced)

Google Forms add-on uses triggers to send a standard email notification when a user responds to the form.

1. Click on Add-Ons, then choose Form Notifications > Configure Notifications.
2. Then configure your notification.

If you want to customize your email notification, you can attach a simple script to your spreadsheet (you will choose data response in a spreadsheet). You will have to modify this code depending on your spreadsheet. (Resource: Jeff Everhart - http://www.jeffreyeverhart.com/2014/01/31/tech-tip-how-to-send-a-confirmation-email-with-google-forms/)

Do the followings:

1. In your form spreadsheet, choose Tools > Script Editor.

2. In Code.gs, enter function as below: (e.values[1] refers to values in Column 1 in your spreadsheet, e.values[2] refers to values in Column 2 in your spreadsheet and so on)

```
function myFunction(e) {
```

The Center for Instruction and Technology
Last Updated: 6/17/2015
```javascript
var userName = e.values[1];
var userEmail = e.values[2];
var date = e.values[3];
var subject = "Form Submitted";
var message = "Thank you, " + userName + " for choosing " + date;

MailApp.sendEmail(userEmail, subject, message);
```

3. Click **Resources > choose Current project's triggers.**
4. Choose **Add a new trigger.**
5. Run **myFunction, From Spreadsheet**, choose “**on form submit**” and click **Save.**
6. Click **Continue.**
7. Click **Accept.**
8. Click **Save.**
9. Click the **Save** button to save the entire script.
10. **Go to Live form** and test your email notification.

Example: A form that has Name, Email, Attend Workshops, Class standing fields.

```javascript
function myFunction(e) {
    var userName = e.values[1];
    var userEmail = e.values[2];
    var attendworkshops = e.values[3];
    var classstanding = e.values[4];
    var subject = "Form submitted";
    var body = "Thank you, " + userName + " for choosing the following(s): 
    + attendworkshops + " in your " + classstanding +" year.";

    MailApp.sendEmail(userEmail, subject, body);
}
```
Print Google Forms in a fillable Format

As of June 2013, you now have the option to print Google Forms. When you print a form, each question is formatted in a way that makes it simple for people to fill in when printed on paper. From your form, just click File > Print.
Appendix

Data validation settings
Currently, only “Text,” “Paragraph text,” and “Checkboxes” questions have support for validation. Each question type has its own validation settings.

Text
Text fields have three types of validation settings:

- **Number**: Ensure the answer is a number of a certain type. For example, you can specify that the answer is a whole number or a number between 21 and 42.
- **Text**: Ensure the answer is text with a certain property. For example, you can restrict answers to text containing the word “lollipop” or only accept email addresses.
- **Regular Expression**: Ensure that the text contains or matches a certain regular expression. (Regular expressions are powerful, but require some know-how. See the “Regular expressions” below to learn more.)

Paragraph text
Paragraph text fields have two possible types of validation settings:

- **Text**: Ensure that the answer can have up to or at least a certain number of characters. For example, you can restrict answers to have at most 100 characters.
- **Regular Expression**: Ensure that the text contains or matches a certain regular expression. (Regular expressions are powerful, but require some know-how. See the “Regular expressions” below to learn more.)

Checkboxes
Checkboxes have two possible types of validation settings:

- **Select at least**: Ensure that at least a certain number of checkboxes are checked in the answer.
- **Select at most**: Ensure that at most a certain number of checkboxes are checked in the answer.
- **Select exactly**: Ensure that exactly a certain number of checkboxes are checked in the answer.

Regular Expressions
Regular expressions provide a way to identify certain types of text, including particular characters, numbers, words, or patterns of characters. Regular expressions are particularly useful in pattern matching, as these searches are not restricted to a specific search term. Instead, searches return patterns that match the expression specified.

To use regular expressions in data validation for "Text" and "Paragraph text," select the Regular expression option in the validation settings.

Terms used in regular expressions
The table below shows a sample of just some of the expressions that Google Docs supports. There are, however, many other supported expressions users can employ.
<table>
<thead>
<tr>
<th>Expression</th>
<th>Description</th>
<th>Example</th>
<th>Matches</th>
<th>Does not match</th>
</tr>
</thead>
<tbody>
<tr>
<td>.</td>
<td>A period signifies any character in the given position.</td>
<td>d.</td>
<td>do, dog, dg, ads</td>
<td>fog, jog</td>
</tr>
<tr>
<td>*</td>
<td>An asterisk after a character signifies a search for that preceding character repeated 0 or more times.</td>
<td>do*g</td>
<td>dog, dg, dooog</td>
<td>dOg, doug</td>
</tr>
<tr>
<td>+</td>
<td>A plus after a character signifies a search for that character displayed 1 or more times.</td>
<td>do+g</td>
<td>dog, dooog</td>
<td>dg, dOg, doug</td>
</tr>
<tr>
<td>?</td>
<td>The previous expression is optional.</td>
<td>do?g</td>
<td>dg, dog</td>
<td>dOg, doug</td>
</tr>
<tr>
<td>^</td>
<td>A caret must be placed at the beginning of a regular expression and signifies that the string starts with the character(s) or sequence placed after the caret.</td>
<td>^[dh]og</td>
<td>dog, hog</td>
<td>A dog, his hog</td>
</tr>
<tr>
<td>$</td>
<td>A dollar sign must be placed at the end of a regular expression and signifies that the string ends with the character(s) or sequence placed before the dollar sign.</td>
<td>[dh]og$</td>
<td>dog, hog, hot dog</td>
<td>dogs, hog, doggy</td>
</tr>
<tr>
<td>{A, B}</td>
<td>The previous expression is repeated between A and B times, where A and B are numbers.</td>
<td>d(o{1,2})g</td>
<td>dog, dooog</td>
<td>dg, dooog, dOg</td>
</tr>
<tr>
<td>[x], [xa], [xa5]</td>
<td>A character set indicates that just one of the given character(s) should occur in the current position. For the most part, any characters are valid within brackets, including characters mentioned previously in expressions: [xa,$5Gg.]</td>
<td>d[ou]g</td>
<td>dog, dug</td>
<td>dg, dOg, dooog</td>
</tr>
<tr>
<td>[a-z]</td>
<td>A character set range signifies a search for a character within the given range of characters. Common ranges include a-z, A-Z, and 0-9. Ranges can be combined into a single range: [a-zA-Z0-9]. Ranges can also be combined with character sets (mentioned previously): [a-zA-Z,&amp;*].</td>
<td>d[o-u]g</td>
<td>dog, dug, dpg, drg</td>
<td>dg, dOg, dag</td>
</tr>
<tr>
<td>[^a-fDEF]</td>
<td>A character set beginning with a ^ signifies a search for a character that is not within the given set.</td>
<td>d[^aeu]g</td>
<td>dog, dOg, dig, d$g</td>
<td>dg, dag, deg, dug</td>
</tr>
<tr>
<td>\s</td>
<td>Any white space character.</td>
<td>d\sg</td>
<td>d g, d[TAB]g</td>
<td>dg, dog,</td>
</tr>
</tbody>
</table>
Examples for Data Validation:

1. **Question Title**: What is your email address?
   - **Help Text**: 
   - **Question Type**: Text
   - **Data validation**: Text, Email address
   - **Their answer**: 
   - Please provide a valid email address!
   - **Done**: Required question

2. **Question Title**: What is your name
   - **Help Text**: 
   - **Question Type**: Text
   - **Their answer**: 
   - **Data validation**: Text, Does not contain
   - @usfcs.edu
   - Enter Full name, not email address!
   - **Done**: Required question

3. **Question Title**: How many units have you completed for Electives?
   - **Help Text**: 
   - **Question Type**: Text
   - **Their answer**: 
   - **Data validation**: Number, Whole number
   - Custom error text
   - **Done**: Required question
Question Title: Choose a number between 21-42
Help Text:
Question Type: Text

Data validation:
- Number: Between 21 and 42
- Enter valid number between 21-42

Done
- Required question